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1. Introduction

1.1 Purpose of this document
This is the final test specification, the document where all tests that been have performed on the Low effort Component Composition tool (LoCo) will be presented, along with the results.
1.2 Intended Audience
The primary audience for this document is the customer Rikard Land and the team behind LoCo.
1.3 Scope
This document provides full test case coverage of both the graphical designer tool, and the code generator DLL.

1.4 Definitions and acronyms
1.4.1 Definitions
	Keyword
	Definitions

	SaveCCM

	Component model intended for embedded control applications in vehicular systems.

	Squad
	One of the sub groups

	DLL
	Dynamic Link Library

	GUI
	Graphical User Interface

	Savecomp.dtd
	The interface between GUI and Code generator

	Component type
	An abstraction of Switch/Component/Assembly


1.5 References
	Document identity
	Document title

	1
	SaveCCM – a component model for safety-critical real-time systems

	2
	SAVEComp - a Dependable Component Technology for Embedded Systems Software

	3
	Towards a Dependable Component Technology for Embedded System Applications

	4
	SaveCCM: An Analyzable Component Model for Real-Time Systems

	5
	Tool for Component Composition (CoCo)

	6
	Document type descriptor (DTD)

	7
	Low effort Component Composition tool (LoCo) – Project description

	8
	Low effort Component Composition tool (LoCo) – Requirements definition

	9
	Low effort Component Composition tool (LoCo) – Design description

	10
	Low effort Component Composition tool (LoCo) – Acceptance test specification

	11
	Low effort Component Composition tool (LoCo) – Final project report


2. Test-plan introduction
The tests performed on the LoCo graphical designer tool can be divided into two main parts; data model persistence and XML validity.

The data model persistence tests are designed to verify that the internal representation of the application model is correct at all times. We have designed the tests to simulate both likely and unlikely user actions in the graphical designer and verified that the generated XML file is correct.

The XML validity tests are designed to verify that the XML representation of each part of the system is corresponding to the Document Type Descriptor, Savecomp.dtd.

These parts are Switches, Components, Assemblies, Connections, Delegates and IO definition.

Tests have been conducted by creating application models with the GUI and verified the generated XML file with Mozilla Firefox, and also by performing glue code generation for the application model.

3. Test items
3.1 Graphical Designer tool

This module is the main application through which the user interacts and creates application models. The code generator (section 3.2) is callable through the graphical designer tool.

In this module we will test the following:

3.1.1 Repository functionality

The repository is the library of user created components from which the user can select and add them to the application model.
3.1.2 Data model persistence

The workspace must show an exact graphical representation of the internal data model.
3.1.3 Component Preview

The preview of components is a feature that provides the user with a small graphical representation of the selected component and all its ports, before adding it to an application model.
3.1.4 Component type detailed representation

Detailed information about component version, port types and names are shown in a detailed text view whenever the user clicks a component in the repository or in the workspace.
3.1.5 Modeling Feedback

Textual feedback is provided for all important user actions in both the graphical designer and output from the code generator.

3.1.6 Exporting of models

The user is provided three means of exporting an application model; to a XML file corresponding to SaveComp.dtd, a image in BMP format, or as a glue code skeleton through the code generator.

3.1.7 Switch creation

The user can model a switch from an empty base structure; which is an empty switch with no in/out/setports. These can be added and removed later on, and switch conditions can be created to route traffic between the in/outports.

3.1.8 Assembly creation

The user can create either an empty assembly, or an assembly from existing component types in the application model.
3.2 Code Generator unit

This module is called from the Designer tool (Section 3.1.)

3.2.1 Parameterization

Parameters of Code Generator and generated code stored in the "SaveCCMCodeGenerator.dll.config" XML file.

3.2.2 Generation of Eclipse MakeFile C Project
When the code generator is started it creates the application files along with a MAKEFILE which is used by Eclipse to build the application.

3.2.3 Multithreading
Generated code should execute in parallel threads.

3.2.4 Win32 Compatibility
Thread allocation code must be Win32 compatible.

3.2.5 Optimality
Thread allocation must be optimal in the means of parallel computing.

3.2.6 C-code compatibility
Components and glue code are written in standard C.

3.2.7 GUI Integration
Mechanisms for integrating the code generator unit with the graphical user interface.

3.2.8 Debugger
Writing values to in-ports and out-ports before and after executing the components.

3.2.9 Visual/textual feedback
Debugger should display it is results in form of a text field, or by highlighting errors on the graphical model.

3.2.10 Resistance to visual model errors
Errors made in the visual model should be detected.

4. Features to be tested
Modeling behavior of the designer, Component repository persistence, XML generation and parsing, Code generation and resistance to logical errors.
5. Features not to be tested
5.1 G-07 – Save and load feature

This cannot be tested since the requirement was not fulfilled
5.2 G-08 – Import XML model

This was a low prioritized requirement and was therefore not implemented.
5.3 G-09 – Undo

This will not be tested since the requirement was not fulfilled.

5.4 G-13 – Zoom functionality

This will not be tested since the requirement was not fulfilled.

6. Approach
The tests will be performed according to the test plan for each individual test case; no aggressive testing will be performed. The responsible for each test case will be the ones performing them. 

6.1 Approach to configuration and installation
Dalibor Kûsic is responsible for the application install package, the installer package includes software not created by the LoCo team, and we cannot be held responsible for failure of these.

7. Item pass/fail criteria
7.1 Repository functionality

· The repository should maintain a persistent state between program executions.

Pass
· The repository library file is essential for the program to work. If it is manually deleted, the program will not run.

· The repository should take the appropriate action when a stored component cannot be found.

Pass
· If a component is removed from the repository folder, it will also be removed from the repository library file at runtime.

7.2 Data model persistence

· The application should generate valid XML which is an exact representation of the model presented in the workspace.
Pass

· No series of user actions in the workspace have resulted in an invalid data model. However, system memory is limited, and can be a problem when modeling large systems.
7.3 Component preview

· The application should show a small view of the selected item in the repository window.

Fail

· If the component XML descriptor cannot be found, the preview cannot be drawn.

· The preview component should not be allowed any user input for changing name or creating connections.

Pass

· Event handlers are removed whenever the component is drawn as a preview.

7.4 Component type detailed representation

· A detailed view should be provided for the selected component
Pass

· This works for components, as is specified. However it could be useful if it was available for switches and assemblies also.
7.5 Modeling feedback

· The application should provide the user with textual information about what is happening in the program.
Pass

· Every important modeling action is listed in the message window, information and error output from the code generator module is also provided when it is executing.
7.6 Exporting of models

· The application should provide means of exporting the application model to XML, glue code and image
Pass

· The program is able to export an application model to XML
· The program is able to generate glue code from an application model.
· A workspace can be exported to image.
7.7 Switch creation

· A feature for creating switches should be provided.
Pass

· The user can create a switch type base structure
· The user can add IO ports to the switch
· The user can create conditions for switching between in- and out-ports.
7.8 Assembly creation

· A feature for creating assemblies should be provided.
Pass

· The user can create an assembly type base structure
· The user can optionally add free component types to the assembly at creation
· The user can create IO definitions on the assembly
· The user can connect the IO definitions internally with delegate connections
7.9 Component type base functionality

· The common functionality for Switches, Assemblies and Components are grouped in a super class, and should all be able to be removed, excluded from an assembly, renamed, moved, included in an assembly and connect to each other.
Pass

· The user can rename a componenttype
· The user can remove a componenttype
· The user can exclude a componenttype from an assembly
· The user can include a componenttype to an assembly at the same depth level
· The user can move a componenttype inside the workspace.

· The user can connect a port to another componenttypes port
7.10 Installation and Configuration
If any software required by the designer tool or by the code generator is not installed, testing cannot be performed. The .NET framework is one example of software that is needed.

7.11 Documentation problems
All documentation required for testing the application is complete and this will not impede the testing.

8. Suspension criteria and resumption requirements
In order to perform bug fixing in both of our modules, we must perform a new build of the module being tested. Edit-and-continue debug-testing are not a valid solution since this does not simulate the application in a running environment after deployment

9. Environmental needs

9.1 Hardware
A working PC that meets the following requirements is needed for an installation of LoCo:

· 256 Mb RAM

· 500 Mb of free disk space

· 1GHz CPU

· CD-ROM reader
9.2 Software

Windows XP with an installation of the Low effort Component Composition tool is needed for the testing to be run. All software that is needed, except the operating system and Visual Studio .NET comes with the LoCo installation CD. 

10. Test procedure

10.1 Test case specifications

10.1.1 Graphical designer

10.1.1.1 Repository persistence – DESIGNER-001
Description: 
Testing if the repository can maintain its state between program executions or not.
Test type:
Positive: Upon program load, the repository library file is read and the listed component descriptors are loaded into the application.

Negative: repository library file has been removed, application should exit.

Preconditions:
· A valid component consisting of a .c, .h and .xml file must exist in the same location

· The Repository folder must contain the application provided library file.
Input definition:
1. Start the application

2. Select import component and choose a component descriptor.

3. Exit the application

4. Start the application

Output definition:

The repository list should be populated with the newly added component

Remarks:
Known bugs, if the user attempts to add a component that is already located in the repository folder, an exception will be thrown.

10.1.1.2 Switch creation – DESIGNER-002
Description: 
Testing the workflow for creating a switch, and validity of the XML generated from this object.

Test type:
Positive: The user must be able to add a base structure switch, IO ports and conditions. Valid XML must also be generated from the switch.

Preconditions:
No specific preconditions for this test case.

Input definition:
1. Start the application

2. Select Edit->Create switch and provide a name when prompted.

3. Add one or more In- and Out-ports respectively.

4. Add one or more Set-ports.

5. Verify that delete IO works by right clicking on a port and deleting it
6. Select Add Conditions from the right click menu

7. Select between which In- and Out-ports to create a condition.

8. Select the Conditions tab, and choose a Set-port.

9. Choose a value for the condition to pass and click add

10. Repeat 7-8 for the set-ports to include for this condition.

11. Click OK and add the switch to the Application through the right click menu.

12. Generate an XML file from the File->Export menu and validate it with a web browser.

13. Verify port names and values with the values entered when creating conditions and IO.

Output definition:
A valid XML representation of the switch corresponding to the Savecomp.dtd file is expected.

Remarks:
Unless all ports in the model are connected, it is not possible to generate code from the model.

10.1.2 Assembly creation – DESIGNER - 003
Description: Testing the workflow for creating an assembly, and validity of the XML generated from this object.
Test type:  
Positive: The user must be able to create an assembly, with internal componenttypes and IO, with internal delegate connections from these.
Preconditions: 
No specific preconditions for this test case.

Input definition:

1. Start the application

2. Select Edit->Create assembly and provide an ID for the assembly in the top left box.

3. Optionally, it is possible to include free components when creating an assembly, select these from the left list box.

4. Add some components by double clicking them in the repository and give them an identifier.

5. Right click each component that are to be included in the assembly and select add to assembly.

6. Select the newly created assembly in the popup box, centered on the component.

7. When done, right click the newly created assembly and select add to assembly.

8. Choose myApplication, which is the default name of the application unless changed.

9. Add some basic IO to the assembly by Right click->Add IO

10. Verify that delete IO works by right clicking on a port and deleting it

11. Drag some delegate connections from the application to the internal components.

12. Select File->Export->To XML and validate the file with a web browser.

13. Verify that the port names, component names and assembly names are correct with the model.
Output definition:

A valid XML file corresponding to the Savecomp.dtd file is expected.
Remarks:

Unless all ports in the model are connected, it is not possible to generate code from the model.

10.1.3 Component type base functionality– DESIGNER - 004
Description: Testing the base functionality for the Switch/Assembly and Component type.

The features to test are: remove, exclude from assembly, rename, move, include in assembly and connect to componenttype.
Test type:  
Positive

Preconditions: 
No specific preconditions for this test case.

Input definition:

1. Start the application

2. Add a component from the repository; create an empty assembly and a switch, both with simple IO.

3. Include all three types in the application model, and add some basic IO to the application.

4. Connect the componenttypes together by clicking two ports in sequence.

5. Right click the componenttypes and verify that rename works.

6. Right click the componenttypes and verify that delete works.

7. Right click the componenttypes and verify that exclude from assembly works

8. Right click the componenttypes and verify that include in assembly works.

9. Verify that moving the componenttypes works by clicking them and dragging the mouse.
Output definition:

Given valid input when creating IO, no errors should be produced. Connecting componenttypes should not produce any errors if the componenttypes reside on the same level, i.e. in the application or inside the same assembly. Rename should produce an error if a 0 length string is provided as name. Exclude from assembly should always work if the componenttype in question resides on any level inside the application model.

Remarks:

There are countless variations on how to perform this test, but the results should always be the same.

10.1.4 Data model persistence – DESIGNER-005
Description: The application should generate valid XML which is an exact representation of the model presented in the workspace
Test type:  Positive
Preconditions: 

None
Input definition:
1. Start the application

2. Play around with the designer tool and create a couple of models.

3. Export the model to XML

4. Validate that the generated XML really is a representation of the created models.
Output definition:

One valid XML-file should be the output.

10.1.5 Export workspace – DESIGNER-006
Description: Testing the export functionality to image, XML and Glue code.
Test type:  Positive

Preconditions: 

A valid application model inside the workspace
Input definition:
1. Start the application

2. Select Export->to image from the File menu, enter a filename and press OK.

3. Select Export->to XML from the File menu, enter a filename and press OK.

4. Select Generate and choose a destination for the XML file.

5. Validate the XML with a web browser.

6. Open the exported image in a image viewer.

Output definition:
A valid XML file corresponding to Savecomp.dtd is expected; as well as an image representation of the workspace. Glue code for the application model should be produced in the same folder as specified for the XML file when Generate code is selected.
Remarks:
Export to XML and Generate glue code produces the exact same XML file.

10.1.6 Modeling feedback – DESIGNER-007
Description: Testing if the graphical designer provides textual feedback about user actions, and code generator messages.
Test type:  Positive
Preconditions: 

No specific preconditions for this use case.
Input definition:

1. Start the application

2. Create an application model

3. Call the code generator from the file menu
Output definition:

Feedback for all modeling actions and code generator output should be presented in the message window in the bottom of the screen.
Remarks:
If the model is not valid, has unconnected ports or in some way is faulty, the code generation will fail.
10.1.7 Component type detailed representation– DESIGNER-008
Description: Testing if the graphical designer provides a detailed view of the selected component.
Test type:  Positive
Preconditions: 

A valid application model inside the workspace
Input definition:
1. Select a component
Output definition:

The Info form should show detailed information about the component. Version, all ports with names and types, in a tree view.

Remarks:
This works for Components as specified in the requirement, but it could be useful if the detailed view where available for Switches and Assemblies as well.

10.1.8 Component preview – DESIGNER-009
Description: Testing weather selected components are drawn in the preview window.
Test type:  Positive
Preconditions: 


A repository folder with valid components also listed in the library file.
Input definition:
1. Start the application

2. Select a component in the repository

3. Try to perform component related actions on the preview.

4. Repeat from 2
Output definition:

The preview window should display a scaled down view of the selected component.

No user input should be accepted in the preview.

Remarks:

If the XML descriptor of a component is missing, it will be removed from the repository library when selected.

10.2 Code generator
10.2.1 Glue code generation – GENERATOR-001
Description: Testing weather the generator builds the application which was specified in the XML.
Test type:  Positive
Preconditions: 

A repository folder with valid components must be in either the directory where the application is being built or in the path to the file is specified in the XML file.
Input definition:
1. Start the Code Generator.
Output definition:

The code generator will report errors in the XML via events which are handled by the designer tool.
Remarks:

The Code generator calls the Make.exe which builds the whole application and puts it in the “bin” folder of the folder chosen for building the application. After that the built application is automatically started.
10.2.2 Debug

Description: Testing resistance to errors in the XML. And generating the file which describes how the components were executed, and write port values before and after executing the components.
Test type:  Positive
Preconditions: 

A repository folder with valid components must be in either the directory where the application is being built or in the path to the file is specified in the XML file.
Input definition:
1. Start the Code Generator
Output definition:

The code generator will report errors in the Xml via events which are handled by the designer.  The output of the executed application is in a file where it was built.
Remarks:

Using the menu in the built application activate outside triggers and change in port data. After exiting the application the file with the debug date will have been written in the same directory as the built application.
11. Responsibilities

11.1 Developers
· Ensure that everything implemented works satisfactory.

· Fix all bugs that are being found during the testing.

· Testing the software from a white box testers perspective.

11.2 User representative
· Make sure that the requirements have been met.

· Ensure that the software is usable.

· Black-box testing.

· Test the software with some live data to ensure correct result.

12. Risks and contingencies
That an application model is valid does not necessarily mean it is a valid program. Nothing ensures that a application will be as fast or as reliable as a manually created application.
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